I'm running Photoshop CS5 or lower, will your products work?


 

The short answer is no. 

The long answer is maybe but probably not ¯\_(ツ)_/¯ 

Our Brushes, Smart PSD's Actions and Vector Swatches are optimized for CS6 and up only. Some will partially work but none will work 100% as intended. Many products will not be compatible at all. 

You will have no problem using the .tif texture images in our texture packs.

If you are running CS5 or earlier there is a good chance you are running a 5+ year old machine and you may experience slow performance with some of our more vector brushes and effects. This will depend on your processing power and RAM. 

Earlier versions of Photoshop will not be fully compatible with our 5000px brushes or smart PSDs.

 

 

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.